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Druva Documentation

inSync fails to back up custom folder on a MAC device

This article applies to:

  • OS: MAC 10.3 and later
  • Product edition: inSync Cloud and inSync On-Premises 5.5 and later

Problem description

inSync fails to back up a custom folder configured for backup on a MAC device. The client marks the custom folder for backup but displays 0.00 bytes of data backup from the folder.  inSync Client v5.9.5 r58373 displays the custom folder with an exclamation mark on the UI, which indicates a misconfigured folder.  In older versions of inSync Client, the exclamation mark is not displayed.

CustomFolderBackupFail.png

Cause

The issue appears due to one of the following:

  • The path to the custom folder configured in the profile is incorrect.
  • The partition name of the custom folder does not match the partition name on the MAC device. The partition name is case sensitive.

Traceback

inSync logs this issue in the inSyncClient.log file as follows:

[WARNING] Base folder VOLUME/MOUNTPOINT/MyFolder does not exist. Could not backup <folder_name>.

Resolution

  1. Log on to inSync Management Console and click Profile on the menu bar.
  2. Click the name of the profile assigned to the user.
  3. Open the Devices tab and click Edit.
  4. On the Edit Device Backup Configuration window, click Laptops & Desktops and open the Mac tab.
  5. Select the custom folder and check the following:
    • In  Folder to be backed up, verify the exact volume or folder name and also match the upper and lower case folder names.
    • Correct the partition or folder name if required and check the backup data sized displayed against the folder name on the inSync Client UI.
  6. Start a manual backup of the device.