Skip to main content


 

 

How can we help you?

 

Druva Documentation

Download using Direct Download utility fails in authentication is set to SSO

Heads up!

We've transitioned to a new documentation portal to serve you better. Access the latest content by clicking here.

This article applies to:

  • OS: All supported operating systems
  • Product edition: inSync Cloud

Problem description

Data download using inSync Direct Download utility fails if the authentication mechanism is Single Sign-On.

Cause

inSync does not receive a password for authentication when a third-party IdP is used for SSO.

Traceback

Windows Logs:

C:\inSync4
or
C:\ProgramData\Druva\inSync4\Users\<username>\Logs  

Mac Logs: 

 ~/Library/Application\ Support/inSync/


[2019-01-24 21:34:01,764] [ERROR] Exception occurred during webdav access for admin admin@admin.com
[2019-01-24 21:34:01,767] [ERROR] Error <class 'inSyncLib.inSyncError.SyncError'>:Internal error. (#100000001). Traceback -Traceback (most recent call last): File "/opt/Druva/inSync/active/src/inSyncLib/inSyncWDDController.py", line 91, in authDomainUser customerid, valid, ekey, lhids, gvnfeatures = self.srv.auth_admin_basic(email, password, url, addAAS, remoteip=remoteip) File "/opt/Druva/inSync/active/src/drcloud/Lib/MasterRouter.py", line 353, in auth_admin_basic return srv.master.auth_admin_basic(email,password, url, addAAS, remoteip=remoteip) File "/opt/Druva/inSync/active/src/inSyncLib/inSyncRPCBase.py", line 736, in _call_ return self._send(self.name, args, kwargs) File "/opt/Druva/inSync/active/src/inSyncLib/inSyncRPCClient.py", line 619, in _safe_request response = self._rpc._issue_request(methodname, args, kwargs) File "/opt/Druva/inSync/active/src/inSyncLib/inSyncRPCBase.py", line 903, in _issue_request return self._wait_response(seqid) File "/opt/Druva/inSync/active/src/inSyncLib/inSyncRPCBase.py", line 945, in __wait_response raise SyncError(rc, response) SyncError: Internal error. (#100000001)

The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Resolution

Obtain the admin email address and access token using the below steps before you proceed to download data:

  1. Login to the inSync Management Console.
  2. Go to GearIconNew.png(Gear icon) > Settings > inSync APIs tab.
  3. Copy the email address of the administrator mentioned against the Generated by field.
  4. Click Copy to save the API access token.

Use the email address and access token in the procedure below.

Download WebDAV data

  1. Open a terminal or command prompt on your system. 
  2. On Linux or Mac, set the appropriate file permissions to execute the inSync Direct Download utility.

    For example:  
    chmod a+x Users/Ernie/Downloads/inSyncDirectDownload 
  3. On Mac, set the ulimit value to 1024 with the following command.

    ulimit -n 1024
  4.  From the terminal or the command prompt, navigate to folder where the inSync Direct Download utility is downloaded and run the following command specific to your OS.
    • On Linux and Mac:

      ./inSyncDirectDownload -u <admin email id> -p <inSync API token> -l <location for downloading the data> -c <location of the csv file>
    • On Windows: 

      inSyncDirectDownload.exe -u <admin email id> -p <inSync API token> -l <location for downloading the data> -c <location of the csv file
  • Was this article helpful?