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Druva Documentation

Admin has disabled the account error seen on the inSync client

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Problem description

When the backup is triggered on the inSync client the backup fails with error  ‘Admin has disabled the account’

Cause

Scenario 1: If the user is preserved on the inSync admin console side the associated devices under the end-user account are disabled and the backup is expected to fail with this error.

Scenario 2: If the end user is in an active state on the inSync admin console side and the associated device is in the disabled state then the backup is expected to fail with this error

Scenario 3: If both the end user and device are in an active state on the inSync admin console and still the backup fails with the authentication error “Admin has disabled the account”

Traceback

File "inSyncClient/apiServer/ServerUtil.py", line 90, in getFunctionResponse
File "inSyncClient/apiServer/RequestHandlerForMyAccount.py", line 209, in get_password_policy
File "inSyncClient/apiServer/RequestHandlerForMyAccount.py", line 34, in srvconnect
File "inSyncLib/inSyncRPCHelper.py", line 245, in Connect
File "inSyncLib/inSyncRPCBase.py", line 765, in __call__
File "inSyncLib/inSyncRPCBase.py", line 1420, in _safe_request
File "inSyncLib/inSyncRPCBase.py", line 1426, in _issue_request
File "inSyncLib/inSyncRPCBase.py", line 938, in _issue_request
File "inSyncLib/inSyncRPCBase.py", line 980, in __wait_response
SyncError: Admin has disabled the account. (#10000001b)

Resolution

Scenario1 and Scenario2:

  • Go ahead and make the device status active on the inSync admin console and the backups would resume accordingly.

Scenario3:

  • If both the end user and device are in an active state on the inSync admin console and still the backup fails with the authentication error “Admin has disabled the account”
  • Check with the admin if the HDD of the end user was removed from one device and attached to the new device. If such activity was performed then the backups would fail with the same error “Admin has disabled the account”
  • If this is true then the inSync client needs to be reactivated for the end user account on the new machine to which the HDD is attached from the old device to the new device.
  • Reactivating the inSync client will trigger the backup from the machine accordingly
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