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Druva Documentation

Not able to download authkey for a inSync user

Problem description

inSync administrators wish to activate inSync Client for a user using the inSync AuthKey. But when administrators try to download the AuthKey for a user, they see the "Selected user(s) either have enabled privacy settings or user(s) are disabled. AuthKey cannot be downloaded for these user(s)"alert message on the inSync Management Console

authkey_privacy.jpg

Cause

Administrator's access to the user’s backed up data is restricted either from the inSync Management Console > Profiles > User Privacy & Access section 

privacysettings.png

OR
The user must have prevented the administrator from accessing the user's data from the inSync Client. 

clientprivacypermissions.png

Resolution

Based on the listed scenarios, do the steps that follow: 

Scenario 1 

  • Allow admin access to user backup data is disabled.
  • Allow users to edit data privacy settings is enabled.
  • The user is active and can access the inSync Client.

Do the following steps to allow the administrator to access the user data: 

  1. Request the respective user to log into inSync Client on the user's device.  
  2. Access My Account > Data Privacy.  
  3. For inSync Client v6.0.1 and later, uncheck the Data Privacy checkbox. The administrator should now be able to access the user's data. 
    checkbox uncheck.png
  4. For inSync Client versions earlier than v6.0.1, check the Data Privacy checkbox. The administrator should now be able to access the user's data. 
    checkbox check.png

Scenario 2 

  • Allow admin access to user backup data is disabled.
  • Allow users to edit data privacy settings is enabled.
  • The user no longer exists within the organization and cannot access the inSync Client.

Do the following steps to allow the administrator to access the user data: 

  1.  Log into the inSync Management Console and navigate to Users. The Manage Users page appears. 
  2. From the list of users, click on the user for which you want to access the data. The user details page appears. 
  3. Click Edit. The Edit User window appears.
    edit user.png
  4. In the Email address field, enter a valid email address that you can access.
    edit emailadd.png
  5. Click Save.
  6. On the user details page, click More > Reset Password. The Reset Password window appears.
  7. Click Reset Password. A password reset link is sent to the email address that you entered in Step 4.
  8. Access the mailbox and click the password reset link to set a new password for the user's account.
  9. Download and install the inSync Client on a new device. 
  10. Activate the inSync Client on the new device.

    Note: Upon successful activation, inSync initiates the first full backup on the new device. As applicable, you can choose to cancel the first backup.  

  11. Upon successful activation of the inSync Client on the new device, perform Step 2 through Step 4 in Scenario 1 to change the user data privacy settings.

Scenario 3

  • Allow admin access to user backup data is enabled.
  • Allow users to edit data privacy settings is enabled.
  • The user is active and can access the inSync Client.

 Perform Step 1 through Step 4 in Scenario 1 to change the user data privacy settings.

Scenario 4

  • Allow admin access to user backup data is enabled.
  • Allow users to edit data privacy settings is enabled.
  • The user no longer exists within the organization and cannot access the inSync Client.

 Perform Step 1 through Step 11 in Scenario 2 to change the user data privacy settings.