Restoring data through inSync Client on macOS remains stuck and fails with disk I/O error
Problem description
On macOS devices, restoring data through inSync client fails with disk I/O error.
Restoring data from server to Client (Original location, Desktop, Custom location ) also gets stuck and fails with disk I/O error.
Cause
Some of the possible causes for this error are as follows:
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Antivirus scanning enabled for Druva folders on the device.
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Low disk space on the system drive.
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Read and write getting impacted due to very high disk utilization on the device.
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Some other 3rd party applications have a handle on inSync Client.
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inSync Client database files have gone corrupt.
Traceback
inSyncClient.log:
{code}
[2020-04-14 16:42:41,322] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
[2020-04-14 16:42:41,323] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
[2020-04-14 16:42:41,323] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
[2020-04-14 16:42:41,323] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
[2020-04-14 16:42:41,323] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
[2020-04-14 16:42:41,324] [ERROR] Failed to mark restore done for rid=1283268, error: disk I/O error
{code}
Resolution
Do the following steps to identify the possible causes and resolve the issue to avoid further occurrence of the restore error:
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Stop Druva services on the affected device and enable debug logging on the client machine.
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When the error reoccurs, check the file for which the error has occurred. The logs will be available at the following locations:
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The client logs from ~/Library/Application Support/inSync/logs directory.
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The inSync.cfg from ~/Library/Application Support/inSync directory.
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There could be a handle on the restorestate.db file in restorestate folder present in the location: ~/Library/Application Support/inSync/restorestate. Do the following steps for resolution:
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Stop Druva inSync client service
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Rename restorestate folder to restorestate.old
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Launch inSync Client again.
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The restore should work fine if there is any corruption or issue related to restoring the database file.
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If the issue still persists, uninstall the inSync Client and install the inSync Client again. Perform a restore operation and check the behavior. With this resolution, new database files are created without any handle or corruption.
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In case of any machine-specific issues, refer the following logs for further analysis and troubleshooting:
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System Log Folder: /var/log
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System Log: /var/log/system.log
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Mac Analytics Data: /var/log/DiagnosticMessages
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System Application Logs: /Library/Logs
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Console logs
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If the error continues to occur, contact Druva Technical Support for any further assistance or help.
Verification
Restoring data from inSync Client and server should start working as expected.