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Druva Documentation

OneDrive backup failure after Updating user name in Microsoft 365

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Problem description

When the users are provisioned manually to inSync, OneDrive backup fails after updating users name in Microsoft 365.

Cause

Updating users first name or last name in Microsoft 365 may update the users UserPrincipalName attribute.

OneDrive backups relies on UserPrincialName attribute for backups.

Traceback

OneDrive: Error in fetching user details. User user@domain.com Error __get_my_site_endpoint: Error in getting MySite details while requesting URL https://graph.microsoft.com/v1.0/users/user@domain.com?$select=mySite User: user@domain.com Error: Unable to read file. Permission Denied Response Code: 404 Text:{"error":{"code":"ResourceNotFound","message":"User not found",} (#100000046)

Resolution

The issue is resolved by updating the correct UserPrincialName (Email id in Druva) for the user on Druva console. Please follow the below steps to update the users email address.

Procedure

To update the email address of a user,

  1. On the inSync Management Console menu bar, click Users.

  2. Click on a Name to view that user's details.

  3. Under the Details tab, in the Summary area, click Edit.

  4. On the Edit User window, update the Email address and the Name of the user as per your requirement.

  5. Click Save.

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