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Druva Documentation

Troubleshooting authorization prompt on inSync Client for Mac OS while performing backup

 

Problem description

When inSync Client performs backup, multiple authorization prompts are displayed when inSync Client tries to access the following locations configured for backup:

  • Location services
  • Contacts
  • Calendars
  • Reminders
  • Photo

The following prompt is displayed when inSync Client tries to backup the system keychain.

KB_386.png

Cause

The authorization prompts are displayed because inSync Client applications do not have access to the full disk.

Traceback

Error An error occurred:[Errno 1] Operation not permitted: '/Users/xxxxxxxxx/Library/Keychains/ .f1c23220f1'.

Error An error occurred:[Errno 1] Operation not permitted: '/Users/xxxxxxxxx/Library/Keychains/metadata.keychain-db'.

Error An error occurred:[Errno 1] Operation not permitted: '/Users/xxxxxxxxx/Library/Preferences/com-.apple.keychainaccess.plist'.

Resolution

Druva recommends educating inSync Client users to pre-approve inSync by adding it to Full Disk Access in System Preferences > Security and Privacy pane for a seamless backup experience.

Perform the following steps to allow inSync Client applications access to the full disk:

  1. Navigate to System Preferences > Security and Privacy pane.
  2. Click the Privacy tab.
  3. Click Full Disk Access on the left pane.
  4. Click the + button.
  5. Click the Application on the left pane.
  6. Select Druva inSync from the list of applications.
  7. Click inSync and then click Open.
  8. A prompt to apply the modified settings is displayed. Perform the following steps:
    1. Select Quit Now.
    2. Go to Launchpad and start the inSync Client.

This will allow inSync to access these locations that are configured for backup.

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