Backup finishing successfully with 0 Bytes in Google Shared Drive
Problem description
Customer reported a scenario wherein Google Shared Drive backups are finishing successfully with 0 Bytes data visible in the GUI. An Overview would look like this:
Cause
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Normally, without any exclusion, the File Exclusions would be like this:
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The cause for this issue could be related to the Global exclusions being added for Google Shared drive via Auto-Configuration option i.e.
Login to inSync admin console --> Access 'Google Workspace' --> Click on 'Shared Drive' --> Click on 'Auto Configuration' from the top right and then remove the Global exclusions from there.
n example like below:
Traceback
Sample Activity Stream log for Google Shared drive would look like this:
{snip}
[2022-04-20 07:46:16,214] [INFO] Starting Google Shared Drives Backup for Shared Drives Accounting (SV/Michael Yu) Customer 15855
[2022-04-20 07:46:18,509] [INFO] Starting Google Shared Drives backup for Accounting (SV/Michael Yu)
[2022-04-20 07:46:20,273] [INFO] Synchronizing file .:0AKwwnDP1LaynUk9PVA.
[2022-04-20 07:46:21,109] [INFO] Synchronizing file .:0AKwwnDP1LaynUk9PVA completed.
[2022-04-20 07:46:27,024] [INFO] Google Shared Drives Backup Finished for Accounting (SV/Michael Yu)
[2022-04-20 07:46:27,731] [INFO] Updated stats for teamdrive 102545. Stats filesMissed 0, filesSynced 0, sessionid 579334, customerid 15855, cloudapp_backup_status 0
[2022-04-20 07:46:28,412] [INFO] Updated Backup Stats: fscurrentu 0, fstotalu 0, filesTotal 97, filescurrent 96, rptotal 0
[2022-04-20 07:46:28,412] [INFO] TeamDrive: 102545 disconnected, session: 579334, start: Wed Apr 20 07:46:16 2022, end: Wed Apr 20 07:46:28 2022, dur: 12.1987240314, Synchronized files: 0, Missed files 0, dataDone 0
{snip}
Resolution
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Check the Auto Configuration part for the Exclusions i.e.
Login to inSync admin console --> Access 'Google Workspace' --> Click on 'Shared Drive' --> Click on 'Auto Configuration' from top right and then remove the Global exclusions from there.
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Refer below article to check the Exclusions for Google Shared drive:
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Remove All Files and *.* exclusions from the “Excluded File” and “Excluded Folders” and save the configuration.
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Initiate backup and it should go through fine with the correct size of data visible for the Google Shared drive and not as 0 Bytes.