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Druva Documentation

inSync Client fails to launch on a Mac device

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This article applies to:

  • OS: Mac
  • Product edition: inSync Client 6.0.1 and 6.1.0

Problem description

The following issues are observed after installing the inSync Client on a Mac device:

  • inSync Client fails to launch on the Mac device. 
  • inSync icon is not created on the taskbar.
  • inSync process gets killed shortly after opening from Application.

ClientFailsToLaunchOnMac.png

Cause

inSync Client creates a few entries under Keychain Access by default during its installation. However, in absence of sufficient permissions from Mac OS, inSync fails to create the entries under the Keychain Access.

KeyChainAccess.png

The Mac OS fails to provide the required permissions if its System Integrity Protection (SIP) component has developed an issue. As a result, inSync fails to get sufficient permissions to write to the system keychain.  

Traceback

The solitary log saved to inSyncSyncer.log file at ~/Library/Application Support/inSync is as follows:

ClientFailsOnMacTraceback.png

The following traceback is saved to inSyncClienGUI.log

[INFO] Error while config activation , The user key is either invalid or the username no longer exists. (#100000016)

Resolution

Perform the steps provided below to resolve this issue:

  1. Stop or disable the System Integrity Protection (SIP):
    1. Shut down the Mac device (Apple > Shut Down).
    2. Keep Command-R pressed and switch on the device. Keep Command-R pressed until the Apple logo appears.
    3. Wait for OS X to boot the OS X Utilities window.
    4. Select Utilities > Terminal.

      OSXUtilities.png
    5. Run the following commands:
      csrutil disable
      reboot

      TerminalBash.png
  2. Log on to the Mac device and uninstall inSync completely without keeping any settings.

    ClientUninstall.png
  3. Click No when asked to retain inSync settings.

    UninstallClientSettings.png
  4. Reinstall the inSync Client and activate it.

    ClientUninstallInitiate.png
  5. Enable SIP as follows:
  6. Stop or disable the System Integrity Protection (SIP):
    1. Shut down the Mac device (Apple > Shut Down).
    2. Keep Command-R pressed and switch on the device. Keep Command-R pressed until the Apple logo appears.
    3. Wait for OS X to boot the OS X Utilities window.
    4. Select Utilities > Terminal.
    5. Run the following commands:
      csrutil enable
      reboot