inSyncAgent.exe continuously consumes more than 7% of CPU due to Intel display drivers on a 64-bit system
This article applies to:
- OS: Windows
- Product edition: inSync Client on Cloud or On-Premise
Overview
This article explains how to troubleshoot when inSyncAgent.exe continuously consumes more than 7% of CPU, even when inSync Client is not performing any task, including backup. Task Manager displays the memory usage as follows:
inSyncAgent.exe properties display that the handle of ig75icd32.dll uses the Process of Explorer.
Process explorer can be downloaded from: https://docs.microsoft.com/en-us/sys...ocess-explorer
Cause
This issue occurs due to a conflict between the 64-bit Intel display drivers and the 32-bit drivers on the device.
Traceback
Location: Event viewer > Windows Logs > Application logs (Event ID:1000)
{code}
Faulting application name: inSyncAgent.exe, version: 0.0.0.0, time stamp: 0x54e6950d
Faulting module name: ig75icd32.dll, version: 10.18.10.3574, time stamp: 0x535823fa
Exception code: 0xc0000005
Fault offset: 0x001351fb
Faulting process id: 0x153c
Faulting application start time: 0x01d26d22292634fe
Faulting application path: C:\Program Files (x86)\Druva\inSync\inSyncAgent.exe
Faulting module path: C:\windows\system32\ig75icd32.dll
Report Id: 67b678be-d915-11e6-a575-a0a8cd2e3127
{code}
{code}
Problem signature:
Problem Event Name: APPCRASH
Application Name: inSyncAgent.exe
Application Version: 0.0.0.0
Application Timestamp: 54e6950d
Fault Module Name: ig75icd32.dll
Fault Module Version: 10.18.10.3412
Fault Module Timestamp: 52e04aa4
Exception Code: c0000005
Exception Offset: 0012ad6b
OS Version: 6.1.7601.2.1.0.256.4
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
{code}
Resolution
For 64-bit systems:
- Open Device Manager and expand Display adapters.
- Update the display drivers to the latest version. (Device Manager > Display Adapter > Right Click on Intel > Select 'Properties > Driver Tab > Update driver)
- Restart the Druva inSync Client service and launch the inSync Client.
- If inSync Client service does not start and fails to launch inSync Client, perform the following steps:
- Navigate to C:\Windows\SysWOW64 directory.
- Rename the file ig75icd32.dll to ig75icd32.dll.old.
This file can be different depending on the different versions of Intel display drivers installed. - Restart Druva inSync Client service.
- Launch inSync Client.
For 32-bit systems:
- Navigate to C:\Windows\System32 directory.
- Rename the file ig75icd32.dll to ig75icd32.dll.old.
This file can be different depending on the different version of Intel display drivers installed. - Restart the Druva inSync Client service.
- Launch the inSync Client.
Note: Renaming .dll file will not have any impact on the client machine.