Troubleshoot restore failure of backup shares
This article applies to:
- OS: Windows
- Product edition: inSync Cloud and On-Premises
Problem description
The restore operation starts but fails shortly when:
- A user initiates a restore from inSync Client.
- An inSync Administrator initiates a restore from the inSync Management Console
This failure is also observed during restore of backup share as well as restore of system and application settings.
Restore process
When a restore is triggered either from inSync Client or from inSync Management Console:
- A restore request is generated.
- The inSync Client machine receives the restore request and the process to handle this operation on the client is called as inSync.exe.
- If the restore request is for configured backup shares, the restore process is handed over to inSyncUSyncer.exe.
- If the request is to restore the System and App settings, the request is routed through inSync.exe.
- The Server/Cloud also fetches the selected data for restore from the storage.
Note: During this operation, the restore request remains in a Queued state. - After a while, the actual restore begins.
Cause
The process inSyncUSyncer.exe may have stopped causing the restore to fail. In this case, you can find the below trace under inSyncClient.log
[2017-07-26 03:32:15,611] [ERROR] Error while spawning usyncer process for user <USERNAME>: error(1836, 'LoadUserProfile', 'The RPC call contains a handle that differs from the declared handle type.')
Or
[2017-07-26 03:32:15,983] [ERROR] Remote Restore retrying. Error - Cannot reach client gui
Resolution
Perform the following checks:
- Open Task Manager and check if the process inSyncUSyncer.exe is running.
- If the process is not found:
- Stop the Druva inSync Client service from Services.msc and start the service again. Note: You may need Administrative rights for this operation.
- Once the services are up again, verify if the process is present. The pending restore(s) start automatically.