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Druva Documentation

Failed to load authentication key error on the client

 

This article is applicable for:

  • OS: Windows 7.0 and later
  • InSync Cloud and inSync On Premise 5.7 and later

Problem description

inSync Client activation using Authkey fails with several errors. This article covers the troubleshooting steps for each error seen during activation with the Authkey.

Resolution

Each issue is discussed separately as follows:

Issue-1: Failed to load authentication key. Error: too many values to unpack

AuthFailureError.png

Authentication fails with the above error for the reasons mentioned below.

Causes

  • Incorrect configuration in the network settings. 
  • User activation URL is set as - <Name/IP of the server>:<port>
  • To verify this issue, open the .idk file and check if the values are as follows.
servers = ['Test.druvaLabs.local:443:443']

Resolution 

  1. Login to the inSync Admin console>Manage > Settings > Network sub-tab.
  2. Set the User Activation URL as the name or the FQDN only and remove the port number.
  3. The .idk file should now have servers flag value as follows 
servers = ['Test.druvaLabs.local:443']

Issue-2: Failed to load authentication key. Error: The session is invalid (#10000006e)

This error is logged at one of the following locations:

  • C:\ProgramData\Druva\inSync4\users\<user_name\logs >
  • C:\inSync4\users\<user_name>\logs

Cause

This error occurs when there is a network communication issue between the inSync Client and the cloud.

Resolution

Make sure *.druva.com is excluded from the network firewall. Once done, try to activate the client again.

Issue-3: Error: Failed to load authentication key. Error: The user key is either invalid or the username no longer exists. (#100000016)

This error is logged at one of the following locations:

  • C:\ProgramData\Druva\inSync4\users\<user_name\logs >
  • C:\inSync4\users\<user_name>\logs

Cause

This issue occurs when the same authentication key is used again for activation. The key is valid only for one activation.

Resolution

Avoid authenticating the client using the same key more than once. Download the new Authkey (authentication key) from the inSync Management Console to authenticate the client as described below:

To Download the authentication key for the user:

  1. Login to the inSync Management Console.
  2. Go to Manage > Users.
  3. Select the user and click More > Download Authkeys. The Download Authkey window appears.
  4. Select the user device on which you want to activate inSync.
  5. To replace a device, select the device name from the drop-down menu.
  6. To add a new device, select Add new device.
  7. Click Download Authkeys.

A zip file inSyncUserKeys.zip gets downloaded to your system. It contains the authentication keys for the selected user. If you had selected multiple users, the zip file will contain multiple key files. Each key file will be named <user name>.idk.

Before activating the inSync Client on the user's device:

  • inSync Client must be installed on the user's device.
  • Save the Authkey on a folder on the user's device from where it is easy to access.

If you have generated the authentication key multiple times for a user, use the most recent authentication key.

Activate inSync Client on Windows

  1. Login to the user's device and open the command prompt.
  2. Run the following commands:
    C:> cd "C:\Program Files\Druva\inSync\"
    C:\Program Files\Druva\inSync>inSyncAgent.exe 'path\to\the\userkey.idk'

     
  3. Alternatively, double-click the <user_name>.idk file and activate the client on a Windows device.

Activate inSync Client on Mac

  1. Login to the user's device.
  2. Download the attached file mac_load_key.sh and save it to the desktop.
  3. Open the terminal and run the following command:

    Desktop$./mac_load_key.sh /path/to/the/userkey.idk