Troubleshoot restore failure due to an offline client
This article applies to:
- OS: Windows
- Product edition: inSync Cloud and On-Premises
Problem description
The restore operation starts but fails shortly when:
- A user initiates a restore from inSync Client.
- An inSync Administrator initiates a restore from the inSync Management Console
This failure is also observed during restore of backup share as well as restore of system and application settings.
Restore process
When a restore is triggered either from inSync Client or from inSync Management Console:
- A restore request is generated.
- The inSync Client machine receives the restore request and the process to handle this operation on the client is called as inSync.exe.
- If the restore request is for configured backup shares, the restore process is handed over to inSyncUSyncer.exe.
- If the request is to restore the System and App settings, the request is routed through inSync.exe.
- The Server/Cloud also fetches the selected data for restore from the storage.
Note: During this operation, the restore request remains in a Queued state. - After a while, the actual restore begins.
Cause
- The inSync Client is not connected to network or the inSync Client services are offline.
- The client machine is powered off.
Resolution
- Ensure that the inSync Client service is running and the client machine is connected to the network.
- Power on the inSync Client machine and initiate the restore again.