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Druva Documentation

Microsoft 365 backups fail after multi-factor authentication is enabled for a global admin account

This article applies to:

  • Product edition: inSync Cloud

Problem description

Office 365 backups fail after enabling multi-factor authentication and cloud app status is displayed as Not Connected

O365BackupFailure_rebranding.png

Cause

Microsoft 365 issues a refresh token every 10 days. inSync fetches the token and it is validated by the global admin account. If the refresh token stored under inSync fails to match with that of Microsoft 365, the backups fail. The refresh tokens can be disqualified by an event where the global admin is enabled with  multi-factor authentication.

Resolution

Use the following steps to reconfigure Office 365 with the global admin account for which multi-factor authentication is enabled.

  1. Login to inSync Management Console and go to Data Sources > CloudApps.
  2. Select Microsoft 365 and click Configure. The Microsoft 365 sign in page opens.
  3. Sign in with the same global admin credentials that were enabled with the multi-factor authentication.