IMD of inSync Client fails on Windows devices having hostname longer than 15 characters
This article applies to:
- OS: Windows
- Product edition: inSync Cloud and On-Premise
Problem description
When attempting to use the Mass Deployment Tools for endpoints, a failure occurs where the deployments do not occur as expected. The uploaded CSV has the right values for email-id, hostname, device-id, device-id type, and username. The issue is observed especially when the hostname is used as the identifier in the activation process. However, it also occurs when the activation process starts and inSync queries the Netbios name instead of the hostname, which returns a truncated value.
Cause
During the inSync Client activation, Windows OS returns a 15-character string due to the naming conventions used for computers, domains, sites, and OUs in the Active Directory.
Traceback
inSyncClientGUI.log:
Windows:
For inSync Client up till version 5.5: C:\inSync4
For inSync Client version 5.8 onwards: C:\programdata\druva\inSync4
Mac:
/Users/support<username>/Library/Application Support/inSync
[2019-02-09 02:47:49,664] [INFO] IMDv4 - Hardware Identifier(s) :
{'serial-number': u'VMware-56 4d 78 c9 92 c8 24 bd-36 df ee a6 4f 98 c1
fb', 'uuid': u'C9784D56-C892-BD24-36DF-EEA64F98C1FB', 'hostname':
u'WINDOWS-TEN-RAK
The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.
Resolution
Since the issue is not with inSync, you need to use the NetBios names in the input CSV file uploaded to the cloud. This allows the computer name to match during the activation.
Run any one of the following commands from the Windows command prompt to get the Netbios name of the device:
hostname
command:
nbtstat -n
command: