Exchange Online restore fails due to restore API limitation
This article applies to:
- Product edition: inSync Cloud
Problem description
Exchange online restore fails with an internal error:
The primary SMTP address must be specified when referencing a mailbox.
Cause
Due to the Exchange restore API limitation, the primary SMTP address of the user must match with the email address registered in inSync.
Traceback
For procedure to download logs, see inSync user log files
++snip++
[2018-12-22 17:55:46,035] [ERROR] WRKID-22466 cloudapp-6091/799812/1003142/Exchange Online: Error creating mail folders. User: xyz@xyz.com. Error: Internal error. Response Code: 500 Text:<?xml version="1.0" encoding="utf-8"?><s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><s:Fault><faultcode xmlns:a="http://schemas.microsoft.com/exchange/services/2006/types">a:ErrorNonPrimarySmtpAddress</faultcode><faultstring xml:lang="en-US">The primary SMTP address must be specified when referencing a mailbox.</faultstring><detail><e:ResponseCode xmlns:e="http://schemas.microsoft.com/exchange/services/2006/errors">ErrorNonPrimarySmtpAddress</e:ResponseCode><e:Message xmlns:e="http://schemas.microsoft.com/exchange/services/2006/errors">The primary SMTP address must be specified when referencing a mailbox.</e:Message><t:MessageXml xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types"><t:Value Name="Primary">xyz@abc.com</t:Value></t:MessageXml></detail></s:Fault></s:Body></s:Envelope> (#100000001)
++snip++
Resolution
Ensure the user's primary SMTP address and the email address registered with inSync are same. You can either change the email address registered in inSync or in Microsoft 365 admin center. The procedures for both are provided below:
To change the email address registered in inSync:
- Login to the inSync Management Console and click Users.
- Click the user name. This opens the user details page.
- On the Summary tab, click Edit.
- Replace the email address with the primary SMTP address and click Save.
To change the primary SMTP address in Microsoft 365 admin center:
- Login to Microsoft 365 admin center.
- Click Users.
- From the drop-down list, select Active users.
- Select the user name and click Edit next to the username.
- From the already populated aliases, set the email address registered in inSync as primary.
- Click Save.
Verification
Restores should succeed without errors.