Skip to main content
Druva Documentation

Web Browser compatible with TLS 1.1 and above required to access Druva Support Portal

 

 

Overview

Druva Support portal requires users to upgrade to TLS 1.1 or higher to align with the best industrial practices for security and data integrity. 
Druva is focused on continually improving data security with the help of the latest security protocols. This low-impact change is an effort to maintain the highest security standards and promote the safety of your data.  

What is the change? 

Druva recommends to upgrade your browser to TLS 1.1 or later. TLS 1.0 encryption protocol is disabled to prevent users from accessing Druva Support Portal.

How to test your browser compatibility?

Click this – Browser Compatibility Test link to check if your browser is TLS 1.1 or above and compatible. 

  • If the browser displays the test site without errors, you can easily access Druva Support portal
  • If the browser displays errors, ensure your browsers are compatible with TLS 1.1 or later.

The minimum required action is to enable TLS 1.1 or TLS 1.2 encryption protocol within your browser security settings.

What is the difference in the user experience?

When you try to access Druva Support portal from a web browser using TLS 1.0, the browser displays an error message, since the support portal requires TLS 1.1 and later for HTTPS connections. The error message also provides the recommended steps to resolve the incompatibility.
 
Additional details on user experience specific to the browser and the operating system are outlined below.
 
Internet Explorer in Windows 7 or Newer

IEonWindows7andLater.png 
Internet Explorer in Windows Vista, XP, or Earlier
IEonWindowsVistaXP.png

 
Google Chrome or Mozilla Firefox
GoogleChromOrFF.png

Unknown web browser or operating system

UnknownBrowser.png

  • Was this article helpful?