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Druva Documentation

Unable to launch inSync Management Console

This article applies to:

  • OS: All supported operating systems
  • Product edition: inSync On-Premise

Problem description

While trying to access the inSync Management Console, the following error is displayed.

CannotLoadFile.png

Cause

inSyncServerSSL.key file located at C:\ProgramData\Druva\inSyncCloud\inSyncServer4 is invalid or corrupted.

Traceback

The below log entry is saved to Cportal.log located at C:\ProgramData\Druva\inSyncCloud\logs:

[2018-10-15 16:12:55,619] [ERROR] Failed to load/fetch cloud config. Error : Server not reachable. (#100000011). Retrying...
[2018-10-15 16:13:04,638] [ERROR] Failed to load/fetch cloud config. Error : Server not reachable. (#100000011). Retrying...
[2018-10-15 16:13:13,670] [ERROR] Failed to load/fetch cloud config. Error : Server not reachable. (#100000011). Please check status of inSync Config Server.

Resolution

  • In the absence of a signed SSL certificate for inSync Master Server, perform the following steps to recreate the inSyncServerSSL.key file:
  1. Stop all inSync services and wait for the processes to end on the Task Manager.
  2. Rename the existing inSyncServerSSL.key located at C:\ProgramData\Druva\inSyncCloud\inSyncServer4\ to inSyncServerSSL.key.old.
  3. Start all inSync services and check if the issue is resolved.

    The default inSyncServerSSL.key file will look like as shown below:
    -----BEGIN PRIVATE KEY----- 
        <Myserver.key>
    -----END PRIVATE KEY----- 
    -----BEGIN CERTIFICATE----- 
        <Primary.cer> 
    -----END CERTIFICATE-----

  • If the inSync Master Server is using a signed SSL certificate, ensure the inSyncServerSSL.key file is formatted as shown below:


-----BEGIN RSA PRIVATE KEY----- 
    <Myserver.key>
-----END RSA PRIVATE KEY----- 
-----BEGIN CERTIFICATE----- 
    <primary.cer> 
-----END CERTIFICATE----- 
-----BEGIN CERTIFICATE----- 
    <Intermediate.cer> 
-----END CERTIFICATE----- 
-----BEGIN CERTIFICATE----- 
    <Root.cer> 
-----END CERTIFICATE-----

 

If the above steps do not resolve the issue, contact Druva Support.
 

See also