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Druva Documentation

Device does not activate using IMD and displays authentication error

Problem description

When attempting to perform the Integrated Mass Deployment (IMD), the device fails to activate, even with allowing more than one device in the profile.

Cause

inSync does not allow activation of a device for a new user if the device is already in an activated state of a specific user. In context of the user, the user context A to be activated again and now be under user context B.

Traceback

Message

[2019-12-06 12:55:28,017] [INFO] CFGID-51 IMDv2 ESINGLEIMD: customerid=10371, new_user_email=userb@druva.com, devicename=WIN10VM-SCOTT. While activating user on the device, it is found that another user is already activated on it. And since single_user_per_device is enabled for this customer, not going ahead with user creation.

[2019-03-25 09:49:06,317] [INFO] BADLOGARGUMENT: <type 'dict'> at /opt/Druva/inSync/active/src/inSyncLib/inSyncOracle.py 1077 CFGID-36 IMDv2 ESINGLEIMD: customerid=6615, new_user_email=userb@druva.com, devicename=AXG-5CG81737QG, activated_user={u'usera@druva.com': True, u'S-1-5-21-3129900288-4173637057-1646714126-48946': True}. While activating user on device, it is found that another user is already activated on it. And since single_user_per_device is enabled for this customer, not going ahead with user creation.

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Resolution

By default we turn the restriction to only allow for a device to be activated to one user, the same device cannot belong to multiple users. This will be denied by default and the activation will fail.

We can request that the service desk team turn this off for the given instance, however we should express that this is not the functionality that inSync is designed for (kiosk) and that we should delete the device for the user who no longer requires the device and then activate it under the context of the new user who now requires the device.

By deleting the device, the data is deleted. Ensure that you have downloaded all the required data before deleting the deivce.
You could also delete the user for which the device is associated for as well if this user and all their data is no longer required.

Do the following steps: 

  1. Log in to the inSync Management Console.
  2. Click Data Sources> Devices.
  3. Search for device name that has the Device Status as Enabled.
  4. Click on the Device name to view the device details and the user details to which this device is associated with. Example: usera@druva.com.
  5. Select the check box for this device and select Delete.

This will make this device available for another user and you can now activate the device name under the user userb@druva.com.