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Druva Documentation

Backup fails with disk I/O error

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This article applies to:

  • OS: <Enter the applicable OS, with its version if applicable>
  • Product edition: inSync Cloud/On-Premise/Phoenix/CloudRanger/Druva Cloud Platform (DCP)

Problem description

Backup on inSync Client fails with the following error:
OperationalError: disk I/O error

Cause

This error occurs when hard disk present on the device has bad block.

Check system logs in the event viewer of the affected device to verify the same. This event looks like below.

EventImage.png

Traceback

[2019-03-27 18:50:12,270] [ERROR] Errored while retrieving next change, disk I/O error
[2019-03-27 18:50:12,282] [ERROR] Error <class 'pysqlite2.dbapi2.OperationalError'>:disk I/O error. Traceback -Traceback (most recent call last):
  File "inSyncLib\inSyncSyncer.pyc", line 4030, in estimate
  File "inSyncLib\inSyncSyncer.pyc", line 2498, in estimate
  File "inSyncLib\inSyncState.pyc", line 1446, in estimate
  File "inSyncLib\inSyncState.pyc", line 1368, in emit_next_change
  File "inSyncLib\inSyncSyncer.pyc", line 3965, in check_thread_status
OperationalError: disk I/O error

Resolution

Step-1: Identify the logical drive letter of the damaged hard disk from the Event 7 error

If the device has only a single hard disk, then skip to the next step.

 

 

To identify the disk that has a bad block:

  1.  From System event viewer, note the number after the word "HardDisk" in the Event 7 warning message.

    Example: As you can see at the example screenshot below, the System Event Viewer displays the event 7 alert messin age, on device "Harddisk0".
  2. Download the WinObj (Free) program from Microsoft from the link mentioned below.

    https://docs.microsoft.com/en-us/sys...wnloads/winobj
  3. 3. Extract and run the WinObj.zip file.
  4. From the left pane, expand Device.
  5. Select the Harddisk# (number) referred in the Event 7 error. In this example it is: "Harddisk0".

    WinObj.png
  6. In the left pane under GLOBAL??, sort right pane by symlink and find your Harddiskvolume#(number) label.

    In case of the image below, the error is identified on D drive.

    WinObj2.png

Step-2: Check and repair the file system error using CHKDSK

 

After we have found which hard drive has bad blocks, you can contact the hard disk vendor or use CHKDSK command to check for bad sectors. The CHKDSK command verifies the file system integrity and fixes logical file system errors.

  1. Open the command prompt as an administrator.
  2. On the command prompt window, run the following command:

    chkdsk {drive letter} /R

    AdminCmDPrompt.png

     

     


    The above command checks the entire disk surface for bad sectors and tries to repair them for a single attempt. If data exists in the corrupt sector(s), it may get removed and you may see the difference in the total amount of data present on the affected drive once the scanning process is completed.

     

     



     
  3. Allow the CHKDSK command operation to complete.
  4. View the CHKDSK command log (hard disk's health status) from the Windows Event Viewer using the following steps:
    1. Press Windows+R keys to load the Run dialog box.
    2. Enter eventvwr and press Enter to open the Event Viewer.
    3. From the left pane, go to Event Viewer > Windows Logs > Application.
    4. From the right pane, scroll down and double-click to open the Wininit source.
    5. View the detailed log after a file system check that includes all actions and file system repairs that were made.
    6. To view your disk's health status, scroll down  and read the KB value in bad sectors line.
      The value is 0 (zero) in a healthy file system. If you see a positive value (e.g. "100KB in bad sectors") then the file system has problems, probably because your disk is defective (faulty) due to hardware problems and you need to replace it.

      EventProperties.png

Verification

Again, attempt a backup. Backup should succeed if the disk issue is fixed.