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Druva Documentation

VMware backup proxy not visible or the status is disconnected on Phoenix console

 

Problem description


VMware backup proxy not visible or the status is disconnected on the Phoenix console: [Errno -2] Name or service not known.

Cause

Backup proxies with static IP addresses may experience this issue. When we see the error [Errno -2] Name or service not known, it is because the configuration details like DNS server and gateway given to the backup proxy are not working.

Traceback

Log location: /var/log/Phoenix/main_service.log

  • Telnet (telnet phoenix.druva.com 443 ) from the backup proxy to check cloud connectivity returns the error "telnet: phoenix.druva.com: Name or service not known | phoenix.druva.com: Host name lookup failure".
    Error in the  main_service.log:  
    [2020-04-22 17:39:12,826] [ERROR] Error <class 'socket.gaierror'>:[Errno -3] Temporary failure in name resolution. Traceback gaierror: [Errno -3] Temporary failure in name resolution.
  • You may see the following error even when the connectivity between the backup proxy and cloud is fine. 
    Error in the  main_service.log: 
    'datastore': '<datastore_Name>', 'network_name': 'VM Network'}
    [2020-05-07 17:13:49,392] [ERROR] Error <class 'socket.gaierror'>:
    [Errno -2] Name or service not known. Traceback -Traceback (most recent call last):

Resolution

To resolve issues with DNS resolution, perform the following tasks:

  • Determine if you can ping the DNS server from the backup proxy.
  • Check if the DNS server IP address has changed in your environment.
  • Make a note of the DNS address entered while configuring the backup proxy. To do that, shutdown the backup proxy, go to the Configure Tab - Settings - vapp option (Right hand side Pane), and then network settings.
  • Determine if there are any issues in the forward and reverse lookup zones.
  • Check for the presence of static entries on the DNS server.
  • Change the network.

A few other steps that can help resolve the issue are:

  • Ensure that '*.druva.com' is whitelisted.
  • Check the firewall for any errors.
  • Check the status of the Druva service on the backup proxy and start if required

/etc/init.d/Phoenix status

/etc/init.d/Phoenix start