VMware backup proxy not visible on Druva console
Problem description
The VMware backup proxy is not visible on Druva console. The following is error is displayed in the /var/log/Phoenix/main_service.log:
[info] Verifying proxy host connections.....
[Error] Unable to connect to proxy server: invalid literal for int()with base 10:
[Error] Unable to delete entries: 'PROXY USER'
Cause
This issue is encountered for backup proxy using a static or dynamic IP address and when web proxy is used.
This error is encountered in the following scenarios:
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The web proxy address/username is incorrect or configured but not present in the environment.
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Not able to connect to the proxy server given while configuring the backup proxy.
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If the backup proxy was already updated, it is shown as “Not connected” in the Phoenix Console.
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This issue can also be seen during the activation phase of the backup proxy where the activation fails.
Resolution
- Shutdown the (vCenter) backup proxy and correct the settings for the web proxy. See, Reconfigure backup proxy settings.
- After the settings are corrected, start the backup proxy.
- vCenter/ backup proxy will be visible on the Druva console.