Skip to main content


 

 

How can we help you?

 

Druva Documentation

Unable to login via SSO

Heads up!

We've transitioned to a new documentation portal to serve you better. Access the latest content by clicking here.

 

Problem description

While trying to login using SSO, following error is encountered:
AADSTS50105: Your administrator has configured the application Druva ('a4ffee79-747e-48cb-960f-dxxxxx5a') to block users unless they are specifically granted ('assigned') access to the application. The signed in user 'abc@xxxxx.com' is blocked because they are not a direct member of a group with access, nor had access directly assigned by an administrator. Please contact your administrator to assign access to this application.

Cause

Email address/ User is not assigned to the Druva application that is created in Azure AD.

Resolution

To assign user to Druva application:

  • On the Azure portal, navigate to Enterprise applications > All applications, select Druva application created during initial configuration from the applications list.
  • Click Users and groups > Add user.
  • Select Users and groups on the Add Assignment window.
  • On the Users and groups window, select the Users or Group that you want to assign the Druva App in the Users list.
  • Ensure that the User or Admin account selected has a corresponding account created in the Druva Cloud Platform.
  • Click Select on Users and groups window.
  • Click Assign on Add Assignment window.

Verification

Once the user is assigned please try to login with SSO once again

  • Was this article helpful?