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Druva Documentation

Unable to discover the SQL Database

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Problem description

After installing the Phoenix SQL agent on the server, the SQL database is not visible on the Phoenix Management Console.

Cause

This problem occurs if the logon account under which the Phoenix service is running does not have login enabled in SQL Server Management Studio (SSMS).

Traceback

  1. Navigate to the C:\ProgramData\Phoenix location.
  2. Open the main_service.log file.

[2020-08-26 11:35:52,434] [DEBUG] SqlClusterHelper : instances = [u'<SQL_instance_name>'], command_params={}

[2020-08-26 11:35:52,497] [ERROR] Error[('28000', u"[28000] [Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user '<Name of the service account>'. (18456) (SQLDriverConnect); [28000] [Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user '<Name of the service account>'. (18456)")] while connecting with instance [SQL_instance_name] using SQL Server driver

Resolution

Enable login for the Phoenix Service account using SQL Server Management Studio.

Steps

  1. Log in to the SQL Server Management Studio with an account whose login is enabled.
  2. Expand the Security and click Logins.
  3. Right-click on the service account name and click Properties.
  4. Click on the Status button and in the Login section click Enabled.
  5. Restart the Phoenix agent service.

SQL login.PNG

Verification

Trigger the backup which should now complete successfully.