Troubleshooting "Server already registered" error while activating file agent
Problem description
One of the following messages is displayed during while activating Phoenix file agent:
- Server already registered with Phoenix
- Server display name already exists. Cannot register server with same display name.
Cause
- Phoenix administrator is trying to activate the Phoenix file agent after uninstalling and reinstalling Phoenix.
- Phoenix administrator is trying to activate the Phoenix file agent after first removing the Phoenix server and then readding it to the Phoenix Cloud.
- Phoenix has not cleared up the configuration files upon uninstall.
Resolution
- Uninstall the Phoenix Agent. See Uninstall Phoenix agent from Windows.
- Clean up the configuration folders from the following locations:
- For Windows 2012 server: C:\ProgramData\Phoenix
- For Windows 2008 server: C:\ProgramData\Phoenix
- For Windows 2003 server: C:\Documents and Settings\All Users\Application Data\Phoenix
- Install the Phoenix Agent. See Install Phoenix agent on Windows.
- Activate the Phoenix file agent with new or existing file server token and verify if it is displayed under registered server list on Phoenix Management Console.