Snapshot of VM failed
This article applies to:
- OS: Windows OS version later than 2003
- Product edition: Phoenix
Problem description
VM backups fail with the below error with event logs id 12289.
Snapshot of VM failed. [An error occurred while quiescing the virtual machine. Please retry the backup/restore again.]
Cause
On a system running Windows Server 2003 or later, the OS creates registry information of a storage device connected even for a short time using fiber channel or iSCSI protocol. Over time, multiple entries are created for each device that is connected to the server. Several such entries never get used again. Such orphaned entries cause VSS snapshot creation to fail.
Traceback
Log Name: Application
Source: VSS
Date: 2/20/2019 2:07:33 PM
Event ID: 12289
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: DC1ITPAIP1.revance.com
Description:
Volume Shadow Copy Service error: Unexpected error DeviceIoControl(\\?\storage#volume#{b153e392-3559-11e9-a2c9-005056990173}#0000000000004400#{7f108a28-9833-4b3b-b780-2c6b5fa5c062} - 00000000000004D8,0x00560000,0000000000000000,0,000002D313644FE0,4096,[0]). hr = 0x80070005, Access is denied.
Operation:
Exposing Volumes
Locating shadow-copy LUNs
PostSnapshot Event
Executing Asynchronous Operation
Context:
Device: \\?\storage#volume#{b153e392-3559-11e9-a2c9-005056990173}#0000000000004400#{7f108a28-9833-4b3b-b780-2c6b5fa5c062}
Examining Detected Hidden Volume: Existing - \\?\storage#volume#{b153e392-3559-11e9-a2c9-005056990173}#0000000000004400#{7f108a28-9833-4b3b-b780-2c6b5fa5c062}
Execution Context: Provider
Provider Name: VMware Snapshot Provide
Resolution
Clear such orphaned storage entries with the DevNodeClean tool. Download the tool from the Microsoft download center follow the steps below:
- Download and extract the tool.
- Go to the location where the tool is extracted using the elevated command prompt.
- Run the below command to clear any orphaned or stale entries.
DevNodeDClean.exe /n
- Initiate a Phoenix backup aster this change.
Contact Druva Support for additional help.