Server backups stuck in queue state
Problem description
Server backups stuck in queue state
Cause
- Stuck or Stale Phoenix process
- Parameters in phoenix configuration files(Phoenix.cfg) has missing values.
Traceback
For Scenario where parameters in phoenix configuration files(Phoenix.cfg) has missing values, in the main_service.log file we see below information:
[2023-10-01 00:29:29,002] [ERROR] Error <type 'exceptions.NameError'>:global name 'SyncLog' is not defined. Traceback -Traceback (most recent call last):
pid[12080] stdout[]
File "client\service_util.pyc", line 101, in __create_config_for_service
File "roboLib\roboConfigParser.pyc", line 1275, in create
NameError: global name 'SyncLog' is not defined
[2023-10-01 00:29:29,002] [ERROR] service_util: Could not create configuration file for SQL
[2023-10-01 00:29:29,509] [ERROR] Failed to run command with error :
[2023-10-01 00:29:29,509] [INFO] No open port found in Phoenix process:
Resolution
Scenario 1:
Windows Server
- Cancel any queue jobs from Phoenix Management Console.
- Login to server
- Open Services console(services.msc) and stop Hybrid Workloads Agent Client Service.
- Open Task Manager and kill all Druva or Phoenix related processes.
- Then again Open Services console(
services.msc)
and start Hybrid Workloads Agent Client Service. - Trigger the backup now from Phoenix Management Console.
Linux Server
- Cancel any queue jobs from Phoenix Management Console.
- Login to server
- Stop the Phoenix Agent service using below command:
/etc/init.d/Phoenix stop
- Verify if any Phoenix processes are still running.
ps -ef | grep -i Phoenix
- If any process is still found running, kill the process with the following command:
Kill -9 <process id>
- Start the Phoenix Agent service using below command:
/etc/init.d/Phoenix start
- Trigger the backup now from Phoenix Management Console.
Scenario 2:
- Check under antivirus if any of the Druva processes mentioned in the article has been quarantined.
- Release the process from the antivirus.
- Then run the installation file of the Agent and re-install the agent again. Since the process was quarantined, there is a possibility that the process is corrupted.
- After installation of the agent, kindly re-register the server on the console
- Then trigger a backup and check.
Scenario 3:
- Parameters in phoenix configuration has missing values, then kindly re-register the server on the console
- Verify the Agent status on Druva Console and make sure that it’s Connected
- Then trigger a backup and check.