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Druva Documentation

File Server/Hyper-V/SQL server backup fails with PHOENIX189

 

Problem description

File server, Hyper-V, and SQL server backups in Phoenix can fail with error PHOENIX189 if these servers have migrated to newer servers, and the old servers are still running the Druva agent.

Cause

Phoenix registers every server with a unique device ID for identification. The new server isn't registered with Phoenix yet since Phoenix still has entries of the device ID of the older server.

Traceback


C:\ProgramData\Phoenix\FS\Backup\<Backupset>


Error validating server certificate : (10054, 'WSAECONNRESET')
The session is invalid. (#10000006e)
Failed (Error Code : PHOENIX189)
[2020-02-20 05:07:52,773] [ERROR] Error <class 'inSyncLib.inSyncError.SyncError'>:Dropped network connection. (#100000022) (Error Code : PHOENIX34). Traceback -Traceback (most recent call l
ast):
File "roboSyncController.py", line 312, in start_command_server
File "roboSyncController.py", line 325, in _start_command_server
File "inSyncLib/inSyncRPCServer.py", line 577, in serve
File "inSyncLib/inSyncRPCServer.py", line 212, in serve_forever
File "inSyncLib/inSyncRPCServer.py", line 231, in process_requests
File "inSyncLib/inSyncRPCBase.py", line 1094, in handle_request
File "inSyncLib/inSyncRPCBase.py", line 852, in _issue_request
File "inSyncLib/inSyncRPCBase.py", line 860, in __wait_response
SyncError: Dropped network connection. (#100000022) (Error Code : PHOENIX34)

Resolution

To resolve this issue, perform the following tasks:

  1. Stop the Druva agent service on the old server and rename the Phoenix directory C:\ProgramData\Phoenix to Phoenix_old.
  2. Re-register the new server. This will create a unique device ID for the new server in Phoenix.