Skip to main content


 

 

How can we help you?

 

Druva Documentation

VMware disk restore fails with Internal Error (Error Code : VMWARE VMOMI65535)

Heads up!

We've transitioned to a new documentation portal to serve you better. Access the latest content by clicking here.

Problem description

VMware disk restore fails with Internal Error (Error Code : VMWARE_VMOMI65535)

Cause

An entity with the same name exists in the VMware data center

Traceback

1. Follow the instructions provided in the article How_to_collect_the_detailed_job_logs to retrieve job logs.

2. Extract the logs and go to Phoenix <YYYYMMDD>_<timestamp>.log file to see the below trace back in the logs.

[2021-10-18 21:15:35,887] [ERROR] SyncError: VMware VMOMI: Internal Error

[2021-10-18 21:15:35,888] [ERROR] Error <class 'pyVmomi.VmomiSupport.vmodl.fault.NotSupported'>:(vmodl.fault.NotSupported) {

dynamicType = <unset>,

dynamicProperty = (vmodl.DynamicProperty) [],

msg = 'The operation is not supported on the object.',

[2021-10-18 21:15:35,889] [ERROR] VMware VMOMI: Internal Error  (#10006ffff : vmodl.fault.NotSupported) (Error Code : VMWARE_VMOMI65535)

Resolution

The vCenter events show the following error during restore

 

Note:

That during the disk restore Phoenix will create a new VM and attach the disk to the newly created VM

The new VM that will be created will have "_1" added to the name of the VM being restored

 

Example:

  • If the disk of a  VM with the name "Test" is being restored, the VM will be created with the name "Test_1"
  • So if we are restoring the disk of a VM with the name "Test"
  • The disk restore will fail if an entity with the name "Test_1"  exists in the Datacenter, hence
  • Check the datastore to see if the VM folder with the name "Test_1" already exists
  • The VM may not be  listed in the VM list under "Host and clusters" if it is removed from the inventory
    • Click on the datacenter icon in Center,
    • then Click on VM's tab and check if the VM with name "Test_1"  exists
  • If found delete the VM or the folder with the VM name
  • Delete the VM or the VM folder which has the "_1" added to the name of the VM being restored
  • Try a restore again and it should complete successfully

In full VM restore, we can select a name for the restored VM. Hence if any other name apart from "_1" added to the name of the VM being restored, is selected. The full VM restore should work.