Backup job stuck at 0 percent due to Delayed write failed or Disk is full
Problem description
This article applies to the File server, NAS, SQL, and Hyper-V backups. A backup job might get stuck at 0% with the following errors:
- Delayed write failed
- Disk is full
Cause
This error occurs in the following cases:
- The backup crosses it’s queued phase and is in the running state.
- Disk space is unavailable on the Windows drives.
As there is no space for the OS to operate, you might get File system errors while writing data to a disk.
Traceback
- Download the Phoenix Logs.
- Extract the logs. Access the PhoenixScanner_<Drive letter>.log to determine if the following excerpt is present in the log.
- Phoenix log shows
- level=error ts=2019-05-21T13:07:28.6022888-04:00 filename=statemap_helper.go:222 message="Error inserting into smap"
- level=error ts=2019-05-21T13:07:28.605289-04:00 stack="database or disk is full\\ngoroutine 152 [running]:\nruntime/debug.Stack(0xc005fb30a0, 0xc005f5f6e0
- Event Viewer shows
- Event ID: 50
- Description: {Delayed Write Failed} Windows was unable to save all the data for the file . The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.
- Phoenix log shows
Resolution
- Free up sufficient space on the Windows Drives.
Note: Windows recommends you to leave a minimum of 7-10% free space on each drive so that Windows can defragment them.
- Stop backups for the server until space is created.
- Disable backups for the backup sets from the Phoenix Management Console. Or
- Stop the Druva Phoenix service from the server for which backup failed.
- Can move the Phoenix files to another drive/volume in case there is no option to increase the size.