Skip to main content

How can we help you?

Druva Documentation

Application-aware backup completes successfully with error- Network Adapter is not up on VM

 

Problem description

Application-aware backup completes successfully with error- Network Adapter is not up on VM

Cause

This issue occurs if the application-aware backup is triggered for a virtual machine in which VMware tools are not installed/running.

Traceback

  1. Download the job logs. For more information, see  Logs

  2. Extract it and navigate to file Phoenix<YYYY/MM/DD>-<timestamp>.log and search for the following traceback in the logs:
     

    [2020-07-29 12:33:53,255] [INFO] VM guest:

     (vim.vm.GuestInfo) {

       dynamicType = <unset>,

       dynamicProperty = (vmodl.DynamicProperty) [],

       toolsStatus = 'toolsNotInstalled',

       toolsVersionStatus = 'guestToolsNotInstalled',

       toolsVersionStatus2 = 'guestToolsNotInstalled',

       toolsRunningStatus = 'guestToolsNotRunning',

       toolsVersion = '0',

       guestId = <unset>,

       guestFamily = <unset>,

       guestFullName = <unset>,

       hostName = <unset>,

       ipAddress = <unset>,

    [2020-07-29 13:03:55,104] [INFO] Waiting for network adapter to be running...

    [2020-07-29 13:04:00,119] [INFO] Waiting for network adapter to be running...

    [2020-07-29 13:04:05,133] [INFO] Waiting for network adapter to be running...

    [2020-07-29 13:04:10,139] [ERROR] Network adapter is not up on VM.

Resolution

  1. Ensure that VMware tools service is running on the Guest OS and is not in a stopped or disabled state.

  2. Ensure that VMware tools are up to date on Guest OS. If the tools are outdated, update them using steps provided in Installing and upgrading VMware Tools in vSphere (2004754)