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Druva Documentation

AWS Proxy deployment fails due to AWS Availability Zone limitation

This article applies to:

  • Product edition: Phoenix

Problem description

Phoenix AWS Proxy, along with its associated resources, can be deployed through Cloud Formation Template.

This article discusses one of the reasons fo the deployment failure, the steps to identify its root cause, and the corrective actions to resolve the issue.

Cause

To identify the root cause:

  1. Click the name of the failed CloudFormation stack > check the events for the reason for failure > Resource > click the Physical ID of the nested stack that has failed.

    ResourcesStack.png
  2. To check the reason for deployment failure, click the events section of he nested stack.

    EventsStack.png

    If the Availability zone associated with the subnet does not support the selected instance type during deployment, the below error is logged:

    {snip}
    Your requested instance type (c5.2xlarge) is not supported in your requested Availability Zone (us-east-1e). Please retry your request by not specifying an Availability Zone or choosing us-east-1a, us-east-1c, us-east-1d, us-east-1f, us-east-1b. (Service: AmazonEC2; Status Code: 400; Error Code: Unsupported; Request ID: 9512c71c-1975-4d3b-bc81-d3d8ee9e53bb)
    {snip}


    EventsStackError.png

    The subnets closely associated with the availability zone appear as displayed below:

    SubnetsCloselyAssociated.png

Resolution

Since this is an AWS limitation,  choose the subnet associated with availability zone (AZ) which supports the instance type and rerun the CloudFormation template.

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