Skip to main content

How can we help you?

Druva Documentation

DRaaS failover to AWS failed with error DR4103

 

 

Overview

Windows Server VM hosted on VMware failed to perform DRaaS failover to AWS with error DR4103

Cause

The backup agent during failover process tries to take a console snapshot. Which fails with error: Image could be undeployable.

This usually happens if the value for the registry key of the source VM is set to “Image_State_Undeployable” at below registry path\reg-key :

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\State]"ImageState"="IMAGE_STATE_UNDEPLOYABLE"

The image state value should be IMAGE_STATE_COMPLETE

Traceback

The Image State is IMAGE_STATE_UNDEPLOYABLE. Image could be undeployable.',

Phoenix-SQS-XXXXX.log

[2022-06-14 06:19:31,304] [INFO] [140637630363392] [Conversion] [conversion_id=1544_27435_1229996][phase=1][message_id=1020000] Received message
[2022-06-14 06:19:31,304] [INFO] [140637630363392] [Conversion] [conversion=1544_27435_1229996][phase=1][message_id=1020000] processing message = {u'boot_info_present': False,
 u'conversion_id': u'1544_27435_1229996',
 u'current_step': None,
 u'description': None,
 u'error_code': 6027,
 u'error_details': {},
 u'error_msg': u'6027: : The Image State is IMAGE_STATE_UNDEPLOYABLE. Image could be undeployable.',
 u'message_id': 1020000,
 u'msg': None,
 u'phase': 1,
 u'retry_needed': False,
 u'rm_tw_version': u'11.241.815',
 u'status': u'failed',
 u'step_list': None,
 u'timestamp': 1655187511,
 u'total_steps': None,
 u'type': u'progress-info'}

Resolution

  1. Login to the source VM and change this registry key to IMAGE_STATE_COMPLETE.

KEY: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\State
TYPE: REG_SZ
VALUE: IMAGE_STATE_COMPLETE

  1. After making the change, reboot the VM.

  2. Once rebooted, run a full backup and create a DR copy.

  3. Run the DR failover.

  • Was this article helpful?