Update of CloudFormation stack fails with error: "CloudRangerInitializeSNSProvisioner" - CREATE FAILED
Problem description
Attempting to update the CloudFormation stack in AWS fails with the following error:
"CloudRangerInitializeSNSProvisioner" - CREATE_FAILED
This error indicates that the following resources failed to create in your AWS environment:
[CloudRangerInitializeSNSProvisioner]
You can monitor the stack in the Events tab on your AWS console:
Cause
This error may occur when the administrator attempting to update the CloudFormation stack only has account-level access and has not been granted organization-level access on Druva CloudRanger. In other words, privileges to create or update the CloudFormation stack have not been granted.
Resolution
Ensure that you have been granted Organization-level access, or have administrator privileges to update the CloudFormation stack within the logged-in Organization. If your current privileges only allow Account-level updates, you may request an Organization administrator to upgrade your role on Druva CloudRanger.
To grant or verify administrator access:
- Log into your Druva CloudRanger console and select the Organization for which you wish to grant member access.
- Click the gear icon on the top navigation bar to navigate to the Organization Settings.
-
Navigate to the Members section and select or verify that the Access type is set to admin. Click Save.