EC2 Instance Backup fails in CloudRanger at the step 'aws/monitor/consistentinstancesnapshot'
Problem description
EC2 backup fails at the step 'aws/monitor/consistentinstancesnapshot'
Cause
- The reason for this failure is that one or more AWS components on your EC2 instance(s) is (are) out of date.
- This problem is usually due to at least one of the following reasons:
- The EC2 Instance does not have the 'AWS CLI' installed or is running an old Version of the 'AWS CLI'
- The EC2 Instance does not have the 'AWS Tools for PowerShell' installed or is running an old Version of the 'AWS Tools for PowerShell'
- The EC2 Instance does not have the 'AWS SSM Agent' installed or is running an old Version of the 'AWS SSM Agent'
- The Ec2Launch folder structure missing on the EC2 Instance
- The EC2 Instance does not have an updated Version of the EC2Config
Traceback
"step": "aws/monitor/consistentinstancesnapshot",
"source_account_id": "xxxxxxxx",
"target_account_id": null,
"resource_id": null,
"is_success": false,
"status_message": null,
"status_code": "InvocationDoesNotExist",
"started_at": "2023-04-27T18:30:24.000Z",
"last_checked_at": null,
"finished_at": "2023-04-27T18:30:24.000Z",
"attempts": 1,
"source_account_name": "012345678912",
"body": "{\n \"id\": \"aaaaaaaa-1234-5678-aaaa-bbbbbbbbbbbb\",\n \"job_task_id\": \"xxxxx-eeeeeee-gggggg-wwwww-bbbbfff444445555\",\n \"job_id\": \"1111111111-2222-3333-4444-abcdefghijk\",\n \"depends_on_id\": \"qqqqqqqq-1234-tttt-4444-aaaaaabbbbbb\",\n \"seq\": 3,\n \"step\": \"aws/monitor/consistentinstancesnapshot\",\n \"source_account_id\": \"xxxxxxxx\",\n \"target_account_id\": null,\n \"resource_id\": null,\n \"is_success\": false,\n \"status_message\": null,\n \"status_code\": \"InvocationDoesNotExist\",\n
Resolution
To resolve this issue you need to install / upgrade all the AWS components on your EC2 instances(s).
- Upgrade the 'AWS CLI':
*AWS CLI:
msiexec.exe /i https://awscli.amazonaws.com/AWSCLIV2.msi - Upgrade the 'AWS Tools for PowerShell':
*AWS Tools for PowerShell:
Install-Module -Name AWSPowerShell
https://sdk-for-net.amazonwebservice...dSDKForNet.msi - Upgrade the 'AWS SSM Agent'
*AWS SSM Agent:
https://docs.aws.amazon.com/systems-...ted-agent.html - Install the latest version of EC2Launch on your EC2 Instance.
You can find a step by step guide on how to Install the latest version of EC2Launch on the Amazon link below:
https://docs.aws.amazon.com/AWSEC2/l...-download.html - Install the latest version of EC2Config
https://docs.aws.amazon.com/AWSEC2/l...g_Install.html - Reboot the EC2 Instance
Verification
To Verify if the AWS components are installed and up to date on the EC2 instance we recommend you to follow the steps below:
- To check the Version of 'AWS CLI' you can run the command: aws --version
- To check the Version of 'AWS Tools for PowerShell' you can run the command: Get-AWSPowerShellVersion
- To check the Version of 'AWS SSM Agent' you can run the following command in PowerShell: Get-Service AmazonSSMAgent
- More information on the link below:
- https://docs.aws.amazon.com/systems-...d-restart.html
- To check the EC2Launch Version you can run the command: & "C:\Program Files\Amazon\EC2Launch\EC2Launch.exe" version
- More Information on the link below:
- https://docs.aws.amazon.com/AWSEC2/l...y-version.html
- To check the Version of the EC2Config go to 'Programs and Features' in Windows and check the Version of the Program 'Ec2ConfigService'.